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序

◼为了进行解析、需要建立解析模型，那么如何建模才好？

◼根据解析目的不同，建立针对目的的解析模型。

◼有什么物理现象？
➢ 有对称性、周期性吗？

➢ 是初期设计还是详细设计？

◼根据手头软件的不同做的模型也不同。
➢ 使用CAD软件？

➢ 使用JMAG的建模机能？

局部模型、无外壳 全模型、有外壳
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几何编辑器

形状建模工具

◼ＣＡＤ软件
➢ ３Ｄ ＣＡＤ

➢ ２Ｄ ＣＡＤ

◼其他ＣＡＥ软件的网格编辑器

◼ＪＭＡＧ内置的几何编辑器
➢ 部件建模

➢ 网格建模

◼ＪＭＡＧ内置的形状模板机能
➢ JMAG-Express（电机专用）

➢ 变压器编辑器（高频变压器专用）
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几何编辑器

◼ＪＭＡＧ本体和几何编辑器（及JMAG-Express）的关系
➢ ＪＭＡＧ本体相独立的软件，相当于其他的ＣＡD软件。

➢ 有CAD耦合（后述）的功能。

使用形状来
解析的软件

SolidWorks Catia V5 Creo 
Parametric 
(Pro/E)

NX

几何编辑器 JMAG-Express

定义形状的软件群
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几何编辑器：３D模型

◼JMAG-Designer生成每个部件，再组合生成装配（Assembly）文件。
➢ 以下、展示了３D模型的构成。

➢ 各个部件为Sketch（2D）上作图，再拉伸至３D形状。

Assembly

Part

Sketch

主界面上作为部件来识
别。

拉伸

（Feature）
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几何编辑器：2D模型

◼以下、展示了2D模型的构成。
➢ 各个部件为Sketch（2D）上作图，2D模型只有2阶层。

Assembly

Sketch

主界面上作为部件被识
别。
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几何编辑器：线

定义”圆”的线

为了方便定义圆的中心点的位置的辅助线
（不使用XY坐标指定圆的中心，
而使用从原点的距离、角度来指定）

指定辅助线为

３D建模时所需要的旋转轴

◼形状已经决定了的话，划线、连接、指定面域即可建模。

◼但是，设计上经常要变更尺寸，所以根据作图的好坏评价时的自由度也会不同。

◼作图的线有2种用途。
➢ 表现形状的”线”

➢ 定义其他形状的位置关系的”辅助线”
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几何编辑器：面域（Region）

◼只有线的话，无法得知是形状还是辅助线。

◼在这里，指定复数的线构成的闭合空间为面域（Region），来识别解析对象的部件。

◼３D模型的情况下对拥有面域（Region）的Sketch进行拉伸，给予厚度。

单纯的线

无法进行解析

指定为“Region”

可以进行2D解析

拉伸机能 生成“Solid”

可以进行3D解析

可以进行材料・条件・网格等设定
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几何编辑器：基本操作

◼启动几何编辑器
➢ 启动JMAG-Designer

➢ 菜单的[File]→[Save as ···]

➢ 命名后，生成jproj文件

➢ 左侧的右键[Project]→[Geometry Editor]→[Create Geometry]

◼画线和面域（Region）
➢ 点击[Create 2DSketch]

• 作２D形状。

• 变成[Create 2DSketch]状态后，画面会出现网格。

➢ 点击[Rectangle]

➢ 适当的选择2个点

• 建立矩形的图。

• 默认将作图的直线设定为水平、垂直约束。

➢ 点击[Create Region] 、选择之前生成的矩形

• 试别为四边形的部件，使用生成了Region。

➢ [Create Region]页面点击[Apply]

• 完成了Region的生成。

Region
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几何编辑器：基本操作

◼距离约束的设定
➢ 选择对向的2边

• 选择２个以上的情况，一边按着【Ctrl】或者【Shift】即可连续选择。

➢ 右键→[Constraint Distance]

➢ [Distance]页面上改变距离的数值

• 改变了形状。

• 几何编辑器能够对各个形状的位置关系定义”约束条件”。

• 改变了部件形状的设计探讨时，合理的使用约束条件是十分重要的。
选择2边

11

距离约束
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几何编辑器：基本操作

◼主界面的读入

➢ 右键JMAG-Designer的主界面上[Project]→[Geometry Editor] →[Import Geometry]

• 出现了几何编辑器生成的矩形的面域。

• 几何编辑器的[Back To JMAG-Designer] 也可读入。

◼形状参数化的设定

➢ 右键左侧的[2D Model]→[New Study]→[Magnetic：Static Analysis]

➢ 左侧的[Study]→右键[CAD Parameter]→[Select CAD Parameters]

➢ 勾上2DSketch的距离

• 选择和几何编辑器等ＣＡＤ软件进行数据沟通时需要的项目。

• Distance.X的“X”为操作的次数。第一次为”Distance”、第二次为”Distance.2”。

➢ 点击[Select CAD Parameters]界面的[OK]

➢ 左侧的[Study]→右键[Case Control]→[Show Cases]

➢ 添加想要改变的尺寸，点击[Add Case]

➢ 各个Case的尺寸设为[Distance@Distance.X@Sketch]下的数值

➢ 点击[Show Case]页面的[OK]

➢ 使用Case滚动条来改变当前Case

• JMAG-Designer的主界面上会显示新的形状。
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几何编辑器：3D建模

◼几何编辑器上使用”Sketch”来建模的话，生成的为2D模型。

◼这里可以将Sketch变换到3D模型。

◼转换成Part
➢ 切换到几何编辑器

➢ 右键[Sketch]→[Move to New Part]

• 生成了3D模型的部件”Part”。



14

几何编辑器：3D建模

◼拉伸
➢ 选择[Sketch]，点击拉伸[Extrude]

• 打开[Extrude]界面。

➢ [Extrude]界面点击[OK]

• 生成了3D形状。

• 打开着[Extrude]界面的状态，画面上出现拖拽条。
通过拖动拖拽条，能够改变形状。

• [Rotate] 来改变视角的话，能够确认立体形状。

◼主界面的读入
➢ 右键JMAG-Designer的主界面上[Project]→[Geometry Editor] →[Import Geometry]

• 主界面上出现立方体。
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几何编辑器：拉伸

◼使Region变成3DSolid的话需要进行拉伸。
➢ Extrude

➢ Revolve

➢ Sweep etc.

Extrude Revolve
Sweep

（沿着引导线进行拉伸）
Loft

（将上下面进行平滑地连接）
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几何编辑器：2D、3D约束

◼通过添加约束，可以对图形的长、宽、位置等信息施加限制。

◼约束包含了，定义基本图形之间的位置关系的「2D约束」，和Part之间的位置关系的「3D约束」。

2D约束 3D约束
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几何编辑器：重复约束

◼重复定义了约束的情况，会将相关约束标记为橙色。

◼去除了重复定义的约束时，会回到原来的黑色。

半径约束2个、距离约束1个、有一个多余

去除距离约束

（除重）
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几何编辑器：完全约束

◼设定了足够的约束（完全约束）时，基本图形会成为黑色粗线、黑色点。

设定固定约束、

半径/直径约束

（原点和圆弧为完全约束）
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几何编辑器：编辑状态

◼能够操作的地方会根据，左侧的阶层是否为编辑状态而改变。

Assembly编辑 Part编辑 Sketch编辑

能够进行直线・圆弧等基本图
形的增加、生成Region、
对Region的网格刨分等操作。

能够进行Sketch的增加，
对Sketch的拉伸等3D化操作。

能够进行Part的增加、移动等
设定。
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几何编辑器：主界面的显示

◼几何编辑器生成了”2DSketch”的情况，主界面会显示为”2D Model”，这时只能选择进行2D解析。

◼几何编辑器生成了”Part”的情况，主界面会显示”Solid Model”，这时能够进行3D解析。
➢ 2DSketch和Part混在的情况，会优先作为Part处理。

プロジェクト

2D Model

Solid Model

Mesh Model

Assembly

2DSketch

Part

Extrude

Sketch
Region

Region

Assembly

3D形状

2D的草图

部件的单位

部件的单位
+

+

+

-

-

-

-

-

-
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几何编辑器：主界面的显示

◼解析模型上需要部件。

◼几何编辑器生成的Part（或者是2DSketch）即部件。

◼Part（或者是2DSketch）有复数个Region的情况，部件会组合。

主界面

几何编辑器

组合化

组合化
解除状态

这个部件包含了1个Solid

这个部件包含了复数个Solid

组合的对象
有复数个Solid的Part的图标会有不同。
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主界面：部件的组合化

＜Assembly下面，组合各个不同Solid部件的方法＞

◼右键[Part]，点击[Ungroup]
➢ 这样，会被视作各个不同的部件。

◼[Add Group]或[Create Group]能够再次
生成Group。
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主界面：部件的组合化

＜设定各种条件的时候，对各个Solid设定条件的方法＞

◼在设定电流等条件时，选择部件的话会将全体部件都选上。

◼这时，右键部件选择[Expand Part Groups]，就可分离各个Solid。

◼或者，一边按着【Shift】一边选择部件。

【Shift】
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启动几何编辑器、读取形状的方法

◼启动几何编辑器

➢ 右键Project→[Geometry Editor] →[Import Geometry]

• 从0开始生成形状。

➢ 右键模型→[Restore CAD Link]

• 打开已有的模型形状。

• 打开其他的CAD软件和CAD耦合的形状时，操作也是一样的。

◼读取几何编辑器生成的形状信息

➢ 右键Project→[Geometry Editor] →[Import Geometry]

• 生成新的模型。Study等条件全部清空。

➢ 右键已有的模型→[Update Model]

• 生成新的模型并继承原有模型的Study和条件。

➢ 右键已有的模型→[Replace Model]

• 生成新的模型并替换原有形状。

• 无Study的情况才能选择。
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形状变更时的注意事项

◼不确立CAD连接的话，即便是尺寸发生了变更，形状不会更新。参数化分析时，尤其要注意。
➢ 几何编辑器、其他的CAD软件，都是同样的。

◼不确立CAD连接，追加新Case的时候会出现以下信息。
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形状变更时的注意事项

◼对于设定好材料、条件的形状
➢ 删除部件的话，和这个部件相关的材料或条件等设定会消失。

➢ 追加部件的话，需要对这个部件设定相关的材料或条件等设定。

◼只改变尺寸的话，不会失去部件信息、面信息，所以能够维持各种设定。

部件A

部件B

设定的边界条件

部件A

边界条件

几何编辑器上删除部件
B的话，部件B相关的る
设定信息会被删除。

部件A

部件C

几何编辑器上追加部
件C的话，部件C不会
有任何设定信息。

部件A

部件C

主界面上设定条
件。
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几何编辑器：例

◼设定为了实现参数化的约束条件

◼为了对尺寸作参数化

◼有必要满足这些条件。在这时，需要使用约束条件。

➢ 改变某个尺寸

➢ 不改变无关的形状
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几何编辑器：约束（利用对称性）

◼对于右图的形状作参数化，设定约束条件。

◼转子的形状为镜面对称的形状。进行参数化时可以利用形状的周期性・对称性。

◼选择下图的Region，右键→[Delete]

◼选择下图的基本形状(线)，右键→[Delete]
➢ 之后，利用Region镜面复制机能，再定义删除了的部件。

删除Region 删除线
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几何编辑器：约束（决定基准）

◼固定作为基准点・线。

◼固定原点。
➢ 选择原点，右键→[Fixation]

◼固定基准线。
➢ 选择X轴上的直线，右键→[Fixation]
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几何编辑器：约束（一致约束）

◼为了使点A能在45度倾斜的线上移动，使用一致约束。

◼为了使线L1和线L2为从原点延伸的同一直线，使用一致
约束。

➢ 选择原点和线L1，右键→[Coincident]

➢ 选择线之后，按着【Ctrl】或【Shift】在选择原点的话，就
能同时选择复数个线。

◼同样的，线L1和线L2也设定为一致约束。
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几何编辑器：约束（角度约束）

◼为了使线L1和L2固定在45度的位置，设定角度约束。
➢ 同时选择线L3和线L2，右键→[Angle]

➢ 线L1和线L2因为[Coincident]固定在一起，所以改变角度约束
的数値，线L2和线L1会联动改变。

（参考）指定为60度的情况的例子
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几何编辑器：约束（平行约束・距离约束）

◼为了维持磁铁的形状为长方形，定义以下的约束条件。

✓ 1个为90度

✓ 对边平行

◼线L4和线L7之间为90度。

➢ 选择线L4和线L7，右键→[Perpendicularity]

◼磁铁的对边平行，并且可变。

➢ 选择线L4和线L5，右键→[Distance]

➢ 选择线L6和线L7，右键→[Distance]
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几何编辑器：约束（磁铁的位置）

◼为了改变磁铁的”位置”设定约束条件。

这里以点A为基准点。

◼固定线L8的长度，作为磁铁上面的延长线。

➢ 选择线L8，右键→[Distance]

➢ 选择线L8和线L4，右键→[Coincident]

◼使磁铁的位置可变。

➢ 选择原点和点A，右键→[Distance]

➢ 选择线L2和线L4，右键→[Angle]

点A

线L4
线L8

原点

线L2
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几何编辑器：约束（确认磁铁的位置）

◼改变磁铁位置的例子
➢ 磁铁正常地运动。

➢ 磁铁的两端气隙歪曲。

改变点A的位置
11 mm → 15 mm

改变磁铁的角度
60 deg → 30 deg

初始形状

由于还未对磁铁两端的气隙设定约束条件，无法追随形状的变化。
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几何编辑器：约束（追随的部件形状）

◼改变磁铁位置的例子

◼为了使磁铁两端的气隙形状随着磁铁的运动，
定义约束条件。

◼磁铁的边为基准，设定约束条件
➢ 选择线L6和线L10，右键→[Angle]

➢ 选择线L6和线L11，右键→[Angle]

➢ 选择线L6和线L9，右键→[Distance]

◼另一侧的磁铁的气隙形状也进行同样的设定。

线L6

线L9

线L10

线L11
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几何编辑器：约束（利用对称性）

◼下半部分的Region进行镜面复制后，改变下半部分的尺寸时，上半部分也会连动。
➢ 点击[Region Mirror Copy]

➢ 将[Edge]选择为45度倾斜的直线

➢ 选择磁铁和转子铁心

➢ 点击[OK]
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几何编辑器：约束（确认）

◼在JMAG-Designer中读取形状，尝试改变尺寸。
➢ JMAG-Designer的主界面上，右键[2D Model]→[Update Model]

➢ [Study]→[CAD Parameters]键→[Select CAD Parameters]

➢ 参考模型表示画面的高亮显示、选上右图的约束※，点击[OK]

➢ 右键[Case Control]→[Show Cases]

➢ 点击[Design Table]窗口的[Add Case]，改变尺寸

➢ 拖动Case滚动条来切换表示的Case

※观察高亮处也很难指定尺寸的时候

• 打开几何编辑器左侧的[Constraint]、
把鼠标移至模型表示画面的约束处
约束名会被高亮，可以确认约束条件。

• 右键[Constraint]→[Properties]来重命名。
• 使用模型的更新，把名字反映到JMAG-Designer。
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几何编辑器：约束的总结

固定基准形状
设定基准形状到

相对位置的约束

对随着形状变更联动的
部件形状，设置

约束条件
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几何编辑器：例

绕线・线圈端部、形状模板

◼为了考虑表皮效应，需要考虑线圈的绕线、线圈端部的磁链。因此要对3D的端部形状建模。

◼JMAG拥有能够简单地制作2D的绕线形状或3D的线圈端部形状地机能。

◼此外，可以使用形状模板快速制作其他的形状。
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几何编辑器：绕线模板

◼启动JMAG-Designer

◼打开“WireTemplate.jproj”

◼右键[2D Model]→[Restore CAD Link]

◼右键[Coil.2]→[Edit Sketch]

◼点击[Wire Template]

◼选择全部地基本图形，在选择地基本图形范围内生成绕线。

◼Layout Type：Close Packing、Angle：7.5
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几何编辑器：线圈模板

使用模板机能生成3D电机的绕组。

◼启动JMAG-Designer

◼打开CoilTemplate.jproj

➢ 打开如右图所示的形状。

◼使磁铁的位置可变。

◼右键[Solid Model]→[Restore CAD Link]

➢ 打开几何编辑器。

◼点击[Edit Part]

◼点击[Coil Template]

◼指定如下的尺寸。

➢ Inner Diameter：60

➢ Outer Diameter：80

➢ Start Angle：7.5

➢ Bias Angle：2.0

➢ Full Model Copy：ON

➢ Specify Periodic Angle：ON

• Periodic Angel：90

复制为全模型

指定周期角度
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几何编辑器：形状模板

◼启动JMAG-Designer

◼使用形状模板里有的形状。

◼打开几何编辑器

◼拖拽里面有的任意形状

◼设定参数

◼立方体或螺旋等基本形状、点击的转子、定
子都可以直接使用。
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◼参数化建模

◼案例
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CAD数据的读取方法（２种）的不同

◼读取ＣＡＤ数据
➢ 优点

• 只要满足文件的格式要求，无论什么样的CAD软件都可以用来作图。
➢ 缺点

• 需要对每个生成的形状设定解析模型的各种条件。
※可以利用从文件到模型的更新（后述）。

➢ 支持的文件格式
• ２Ｄ形状（ＤＸＦ、SAT、ＩＧＥＳ）、３Ｄ形状（ＳＡＴ、ＩＧＥＳ等）、网格数据（ＮＡＳ、ＵＮ
Ｖ）

◼ＣＡＤ耦合
➢ 优点

• 可以在习惯的CAD软件上改变模型后，继承各种条件的状态下更新JMAG的形状模型。
• 对尺寸做参数化后能够进行参数化解析。

➢ 缺点
• 需要在同一电脑上安装ＣＡＤ软件和ＪＭＡＧ。
• 需要占用CAD软件和JMAG的License。

➢ 支持的CAD软件
• SolidWorks、CATIA V5、Creo Parametric(Pro/E)、NX
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ＣＡＤ耦合的流程

◼介绍ＣＡＤ耦合的流程。

➢ 启动JMAG-Designer

➢ 菜单[File]→[Open]

➢ 从[文件的格式]下拉菜单选择

• SolidWorks Assembly文件(*.sldasm)

• CATIA V5文件 (*.CATPart、*.CATProduct)

• Creo Parametric(Pro/ENGINEER)文件（*.prt、*.asm等）

• NX （*.prt）

➢ 选择好文件后，自动启动各个ＣＡＤ软件

➢ 使用各个ＣＡＤ软件变更形状的情况，在JMAG-Designer的主界面上，右键[Solid Model]→选择[Replace Model]或者

[Update Model]。

• [Replace Model]只有在没有Study的情况下使用。

• 选择[Update Model]的话，会维持原本Solid模型，读取新的形状信息作为新的Solid模型，原本的Solid模型的各种设定都能得到继承。

• 各个ＣＡＤ软件，进行部件的删除・增加、面的删除・增加时，增加了全新的形状时，需要对这些部分进行相关设定。
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读取ＣＡＤ数据的流程

◼读取ＣＡＤ数据的流程有2种。

◼１

➢ 启动JMAG-Designer

➢ [File]→[Open]

➢ [文件格式]下拉菜单选择以下

• ACIS文件 [2D Entity]（*.sat *.sab）

• ACIS文件 [3D Solid]（*.sat *.sab）

• DXF文件（*.dxf）

• IGES文件 [2D Entity]（*.iges *.igs）

◼２

➢ [File]→[Import CAD File]

➢ 能够选择的文件格式如下。

• SAT、IGES、CATIA V4、CATIA V5、Creo Parametric(Pro/ENGINEER)、Parasolid、STEP、NX、SolidWorks、SolidEdge

• 读取文件时，如果有形状干涉的情况，可以进行使用Healing Function。

• 读取文件时，解析中不需要的Sheet body 可以进行统一删除。
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ＤＸＦ文件的读取选项

◼读取ＤＸＦ文件时。以下几点可能引起问题。

➢ 有多个layer

➢ 尺寸误差导致各个线断开

• 产生气隙

• 产生多余的线

➢ 读取线时，需要手动生成Region

◼通过设定读取选项，可以将这些自动化。
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例

不使用CAD耦合的模型更新

◼只使用导入的CAD文件也可以进行模型更新。

◼但是，无法使用进行参数化，也就是无法用Case Control来进行尺寸变更。
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通过文件来进行模型更新

◼启动JMAG-Designer

◼打开“GearAtoB.jproj”

◼右键[Solid Model] →[Update Model]

◼选择“gearB.SLDPRT”→[OK]

➢ 和确立CAD连接时的[Update Model]相同。

➢ 支持从CATIA V5、NX、Creo Parametric、SolidEdge、SOLIDWORKS、Inventor的CAD文件到JMAG-Designer的导入。
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例

加工已有的SAT文件

◼手上有其他的CAD文件３D形状数据时

➢ 其他的CAD软件数据无法在几何编辑器上作为形状Solid。

➢ 但是，利用直接建模（Solid面的平移、移动、倒角变换）机能的家、能够进行参数化解析。

➢ 此外，以下的机能也能用于2D的Region或者几何编辑器生成的Solid。
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导入形状

◼启动JMAG-Designer

◼[File]→[Open]

◼[文件格式]下拉菜单选择[ACIS Files [3D Solid] (*.sat *.sab)]

◼选择relay.sat，点击[Open]

◼右键[Solid Model]→[Change Link to Geometry Editor]

➢ jproj文件的保存确认界面出现时，指定文件名后保存。

➢ 初始的形状为其他CAD软件的情况，不保留编辑历史。这时，导入文件为几何编辑器的界面上Part内的[Import]。

没有“Sketch”或”Extrude”的
形状作成的历史
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Solid面平移

◼右键想要编辑的[Part]→[Edit Part]

◼点击[Solid Face Offset]

➢ [Offset]设为1

➢ 选择平移的面

➢ 点击[OK]
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参数化解析

◼[Replace Model]来替换模型

◼生成稳态电磁场解析Study

◼参考“几何编辑器（基本操作）”，将平移距离或者倒角半径为参数设定参数化解析模型

➢ 平移值为正的时候为外侧，负的时候为内侧
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Region、Solid的移动

◼同样的，也可以进行Region的平移或移动、Region或Solid的移动。
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电机专用工具

◼介绍使用电机专用工具”JMAG-Express”来定义形状的方法和自定
义尺寸的方法。

◼启动JMAG-Designer

◼[File]→[Save As···]

◼右键[Project]→[Motor Model]→[Creat with JMAG-Express]

◼[Template]→选择[Brushless motor(IPM)]

◼选择[PM_I_D_IV.2]

➢ 出现了电机的画面。

➢ [Dimensions]菜单下可以对电机的尺寸进行改变。

➢ [Materials]菜单下可以变更各种材料。

◼JMAG-Designer的主界面上，右键[Project]→[Motor 
Model]→[Import]

◼设定维度和部分模型化的选项后点击[OK]

JMAG-Express

JMAG-Designer
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电机专用工具

◼JMAG-Express建好的模型，可以在几何编辑器中确认・变更。

◼主界面的左侧右键”2D Model”，选择[Change Link to Geometry Editor]。

➢ 这样就能在几何编辑器中打开。

电机模型：建模

电机模型：导入

几何编辑器打开く

模型更新

JMAG-Express JMAG-Designer 几何编辑器
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变压器专用工具

◼介绍使用变压器专用工具”变压器编辑器”来定义形状的方法
和自定义尺寸的方法。

◼启动JMAG-Designer

◼[File]→[Save As···]

◼右键[Project] →
[Transformer Model]→[Create]

◼选择[Core]页面，点击[Core Type]的[Change]

◼选择[Database]的[TDK]的[EE]的[PC40EE30-Z]，
并点击[OK]

◼选上[Use Center Gap]

◼选择[Grind Both]

◼输入0.15mm
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变压器专用工具

◼选择[Bobbin]页面

◼选择[Bobbin Type]的[Track Bobbin]

◼输入以下尺寸

➢ Space Height（SH） ：14

➢ Space Width（SW） ：3.5

➢ Bobbin Thickness（BT）：1

➢ Axis Width（AW） ：12.7

➢ Axis Height（AH） ：19

➢ Round Radius（AR）：7.5
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变压器专用工具

◼选择[Coil]页面

◼选择[Secondary]

◼右上图的样子作图

◼选择[Primary]

◼右下图的样子作图

◼下栏的S1和P1的高度设为”0.5”
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变压器专用工具

◼[Model Division]上选择[1/4 Model]

◼JMAG-Designer的主界面上右键[Project]→[Transformer Model]→[Import]

➢ 主界面上出现３DSolid模型。

变压器编辑器 JMAG-Designer
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参数化分析流程

预设

A）数值、标志、坐标、文件路径

A1）使用[select Parametric Parameters]参数进行设置

A2）使用公式设置

B）材料

C）点序列

D）尺寸

D1）使用尺寸设置

D2）使用公式设置

运行计算

后处理

E1)响应

E2)响应图
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A1:选择参数增加case

◼载入模型

➢ JMAG-Designer菜单栏中选择[File] → [Open]

➢ 选择项目文件A（*jproj）

➢ 单击[Open]
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A1:选择参数增加case

◼设置参数

➢ 在[Project Manager]中 [Study] 下右键选择 [Case Control] 

➢ 目录中选择[Select Parameters]

➢ 在[Look For:] 中输入”Current”

➢ 勾选[Design Parameter]下[Conditions] > [Current]中的 [Current] 框

➢ 点击 [OK].]
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A1:选择参数增加case

◼增加case

➢ 在[Project Manager]中 [Study] 下右键选择 [Case Control]

➢ 目录中选择 [Show Cases]

➢ 出现 [Design Table] 对话框

➢ 选择[Add Case]

➢ 修改电流值
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A2:使用公式增加case

◼设置电流源

➢ 在[Project Manager] 中右键选择[Circuit] 

➢ 选择[View]

➢ 电路图中双击 [Current Source (I terminal)] 
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A2:使用公式增加case

➢ 在[Function]下右键选择 [Frequency (F):]对话框

➢ 选择[Equations] 

➢ 点击 [Add]

➢ 设置参数

➢ 点击[OK]
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A2:使用公式增加case

➢ 删除[Frequency (F):]中原有的数字

➢ 右键选择[Frequency (F):]

➢ 选择[Insert Variable] > [f (60)]
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A2:使用公式增加case

◼设置[Step Control]

➢ 在 [Study]上点击右键

➢ 选择 [Properties]

➢ 在[Step Control]中右键选择 [End Time] 

➢ 选择[Equations]

➢ 点击 [Add]

➢ 设置参数

➢ 删除 [End Time]中原有值

➢ 右键选择 [End Time]

➢ 选择[Insert Variable] > [T (1/f)]
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A2:使用公式增加case

➢ 设置参数

➢ 删除 [End Time]中原有值

➢ 右键选择 [End Time]

➢ 选择[Insert Variable] > [T (1/f)]
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A2:使用公式增加case

➢ 设置参数

➢ 删除 [End Time]中原有值

➢ 右键选择 [End Time]

➢ 选择[Insert Variable] > [T (1/f)]
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B:使用材料增加case

➢ 在 [Toolbox]中选择 [Materials]选项卡

➢ 在[Look For]输入 “50A350” 

➢ 将 [50A350]拖到[Project Manager]下相应的零件上
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B:使用材料增加case

➢ 在[Project Manager] 下[Study] 右键选择 [Case Control] 

➢ 选择[Select Parameters]

➢ 在[Look For] 中输入“Core”

➢ 勾选 [Material]框

◼设置参数
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C:使用点序列增加case

➢ 查看电路

➢ 双击[Current Source (1 terminal)]

➢ 在[Point Sequence]中选择 [<new>]

➢ 输入右侧表格中数值

➢ 点击[OK].

◼设置电流源参数
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➢ 在[Project Manager] 下[Study] 右键选择 [Case Control] 

➢ 选择[Select Parameters]

➢ 在[Look For] 中输入“Current”

➢ 勾选 [Time dependency point array]框

◼设置参数

C:使用点序列增加case
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➢ 在[Project Manager]下右键选择 [Project]

➢ 选择[Geometry Editor] > [Create Geometry]

➢ 点击 [Save As]

➢ 定义文件名，如“D1”

➢ 点击 [Save].

◼启动几何编辑器

D1:形状尺寸参数化
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➢ 选择[File] > [Open] 

➢ 选择A (*.jmdl)

➢ 点击[Open]

➢ 在 [Sketch]上右键选择 [Edit Sketch]

➢ 将鼠标指针放在矩形的底边上，然后单击鼠标右键

➢ 选择[Constraint (Distance)] 

➢ 点击[OK]

➢ 在[Model Manager]中的[Sketch]下展开[Constraint]

➢ 右键选择[Distance]

➢ 选择[Properties]

➢ 在[Name]中输入名称，例如“L1”

➢ 点击 [OK]

➢ 在[Sketch]上右键，选择 [End Sketch]

◼设置形状约束

D1:形状尺寸参数化
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➢ JMAG-Designer中 在[Project Manager] 中[Project] 上点击右键.

➢ 选择[Geometry Editor] > [Import Geometry

➢ 在[2D Model]上点击右键

➢ 选择[New Study] > [Magnetic static analysis]

➢ 在[Project Manager] 中[Project] 上点击右键选择 [CAD Parameters] 

➢ 选择[Select CAD Parameters] 

➢ 在[Look For] 中输入 “L1” 

➢ 在[Design Parameter] 中[L1]下选择 [Distance]

➢ 点击[OK]

◼设置设计参数

D1:形状尺寸参数化
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➢ 在[Model Manager] 下 [Assembly]上右键

➢ 选择[Equations]

➢ 点击[Add]

➢ 设置一个参数

➢ 点击 [OK]

➢ 设置多个参数，如右表

➢ 点击 [OK]

◼关联设计参数

D2:公式设定形状尺寸
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➢ 在 [Sketch] 上右键选择 [Edit Sketch]

➢ 将鼠标指针放在矩形的底边上，然后单击鼠标右键选择 [Constraint (Distance)] 

➢ 删除[Distance]中原有值

➢ 在[Distance] 中点右键，选择 [Insert Variable] > [L1 (100)]

➢ 点击 Click [OK]

➢ 在[Sketch]中展开 [Constraint] 

➢ 右键选择 [Distance].

➢ 选择 [Properties]，重命名“L1”

➢ 点击 [OK].

➢ 同样方法将左边设置“L2”

➢ 右键 [Sketch]选择中选择[End Sketch]

◼设定尺寸约束

D2:公式设定形状尺寸
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➢ JMAG-Designer中 在[Project Manager] 中[Project] 上点击右键.

➢ 选择[Geometry Editor] > [Import Geometry

➢ 在[2D Model]上点击右键

➢ 选择[New Study] > [Magnetic static analysis]

➢ 在[Project Manager] 中[Project] 上点击右键选择 [CAD Parameters] 

➢ 选择[Select CAD Parameters] 

➢ 在[Look For] 中输入 “L1” 

➢ 在[Design Parameter] 中[L1]下选择 [Distance]

➢ 点击[OK]

➢ 同样方法设置“L2”

◼设置设计参数

D2:公式设定形状尺寸
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➢ [Study] 上点右键，选择 [Run All Cases]，待运行完
成

➢ 在[Results]  中[Graph] 上点击右键

➢ 选择[Coil Flux-Linkage] > [Show All Cases] 

➢ 点击[Calculation

➢ 选择[Response Graph Data] 

➢ 设置下表参数

➢ 点击[OK]，点击 [Register as Response Data].

➢ [Coil Flux-Linkage<FL>] 添加在 [Response Graph] > 
[Response Data]中

➢ 点击[Close

◼设置响应值

EF：设计参数评估图显示
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➢ 在[Response Graph] 中右键选择 [Graphs]，并点击
[Project Manager] 

➢ 设置右表参数

➢ 点击[OK]

➢ [Coil Flux-Linkage versus I] 添加到[Graphs] 下方

◼生成响应图

EF：设计参数评估图显示
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➢ 极数：8

➢ 槽数：48

➢ 绕组：整距绕组

➢ 形状图形：使用形状图形库创建，极数和槽数已参数化

➢ 绕组：使用绕组编辑器建模

◼模型

极、槽数参数化



86

➢ 在[Project Manager]上右键选择 [2D Model]，选择 [Restore CAD link] 

➢ 右键选择[2D Model] > [Study] > [CAD Parameters] ，选择[Select CAD Parameters]

➢ 在[Look For]中输入 “SLOTS” ，并勾选 [SLOTS]框

➢ 在[Look For]中输入 “POLES” ，并勾选 [POLES]框

◼模型

极、槽数参数化
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➢ 右键选择[Study] > [Case Control]，选择 [Equations]

➢ [Equation] 中选择 [Add]

➢ 在[Edit Equation] 对话框中设置下表参数

➢ 设置完成后点击[OK]

◼创建和关联变量

极、槽数参数化
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➢ 右键选择[Study] > [Case Control]，选择 [Equations]

➢ [Equation] 中选择 [Add]

➢ 在[Edit Equation] 对话框中设置下表参数

➢ 设置完成后点击[OK]

◼创建和关联变量

极、槽数参数化
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➢ 右键选择 [Study] > [Winding] > [Region Setting] > [Winding Region，选择 [Edit] 

➢ 删除[Number of Slots]中原有值，右键选择[Insert Variable] > [SLOTS (48)]

➢ 删除[Number of Poles]中原有值，右键选择[Insert Variable] > [POLES (8)]

➢ 点击[OK]

◼关联变量

极、槽数参数化
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➢ 右键选择 [Study] > [Conditions] > [Rotation Periodic Boundary]，选择 [Edit]

➢ [Periodicity]设置中选择[Automatically Update from Winding Setting] 

➢ 点击[OK]

◼边界条件设置

极、槽数参数化
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案例

➢外部CAD文件导入

➢图形修正

➢定子

• 设置约束

• 设置特征

➢转子

• 设置约束

• 设置特征

➢设置参数

➢定义形状参数化
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➢ 新建项目文件，进入几何编辑器，导入dxf文件。

◼导入形状文件

外部CAD文件导入
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➢ 导入文件为dxf格式，定、转子位于同一草图。需要将图形划分为定子、转子草图，并删减为最小单
元。

◼CAD文件处理

图形修正
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➢ 删除多余图形，并重新创建面域region。

◼CAD文件处理

图形修正

创建面域并重命名

Rotor Core

shaft

Magenet2

magnet

删除圆角
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➢ 在定子外圆上点右键，选择Constraint(Radius/Diameter)进行外径设置。在对话框中将Type选为直径。在左侧
Constraint下Radius/Diameter上右键，选择属性，重命名为SD1:Outside Diameter of Stator。

➢ 同样方法设置定子内径，并重命名为SD2:Inside Diameter。

定子-设置约束
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➢ 按住ctrl，选中齿宽的两条边，右键选择Constraint(Distance)，之后在左侧Constraint下方找到distance，重命名
为SW1:Tooth Width

定子-设置约束
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➢ 同样方法依次设置如下尺寸约束。

定子-设置约束

齿尖宽
SW2:Tooth Fang Width

定子轭部厚度
SW4:Core Back Width

（注意：此处应选择两个圆弧）

齿尖深度
SW2:Tooth Fang Width

齿尖长
STD1:Tilt Length
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➢ 设置角度约束。按住Ctrl，选择上下两边，右键，选择Constraint(Angle),定义中线与从参考线夹角。在左侧
Constraint下方选择定义好的角度约束，右键选择属性，重命名为Half of the Center Angle，即为中心角一半。

定子-设置约束
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➢ 设置位置约束。在原点上点击右键，选择Constraint(Fixation)，即将原点固定。同样方式将X轴上边设置为固定。
固定完成后图中会出现钥匙图形。

定子-设置约束

➢ 设置垂直约束。按住Ctrl键选择绕组外围两边（左图），右键选择Constraint(Perpendicularity)。设置完成后，图
中会出现垂直图形。同样方式设置右图中齿尖处两边。
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➢ 设置同步约束。按住Ctrl键，选择原点和绕组上边，右键选择Constraint(coincident)，使原点位于绕组上边线的延
长线。同样方法设置绕组上边线和定子上边线同步，X轴线与齿尖线交点同步，

定子-设置约束

➢ 设置同心约束。按住Ctrl键，选中齿尖处两弧线，右键选择右键选择Constraint(concentric)。设置完成后，图中会
出现同心图形。同样方法设置定子外径圆弧、轭部圆弧。



102

➢ 设置圆角。工具栏中选择圆角工具，之后设置圆角半径，并选择夹角线，重命名为SF1:Teeth Top R 。

➢ 同样方法设置定子槽内侧圆角。

设置特征（Feature）
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➢ 设置镜像。选择面域镜像复制，选择对称边，选择定子铁芯作为镜像复制对象，合并面域。

定子-设置特征（Feature）

对称边

定子铁芯合并面域
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➢ 设置圆周镜像。选择面域圆周镜像复制，选择原点为旋转点，选择定子铁芯作为镜像复制对象，旋转角度为360/48度，
镜像个数为6，合并面域。

定子-设置特征（Feature）

定子铁芯

合并面域

注：位置确定之后
的形状图形，线会
变粗。
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➢ 同样方法设置绕组镜像。因为绕组设计为双层绕组，所以不需要选择面域合并。定子设置完成。

定子-设置特征（Feature）
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➢ 距离约束（distance）

转子-设置约束

上磁钢宽度

名称：MW1:Upper Magnet Width

上磁钢厚度

名称：MT1:Upper Magnet Thickness

上磁钢位置

名称：DMAG1:Position of Upper Magnet
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➢ 距离约束（distance）

转子-设置约束

下磁钢宽度

名称：MW2:Lower Magnet Width

下磁钢厚度

名称：MT2:Lower Magnet Thickness

下磁钢位置

名称：DMAG2:Position of Lower Magnet



108

➢ 距离约束（distance）

转子-设置约束

孔宽度

名称：RW2:Excess Slit Thickness1

缝隙

名称：RS:Slit Gap
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➢ 半径/直径约束（Radius/Diameter）

转子-设置约束

外直径

名称：RD1:Outside Diameter

轴直径

名称：RD2:Shaft Diameter
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➢ 固定约束（Fixture）

转子-设置约束

原点固定 轴底边固定 转子底边固定
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➢ 平行约束（Parallelism）

转子-设置约束

孔边平行
磁钢边平行孔边平行
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➢ 平行约束（Parallelism）

转子-设置约束

磁钢边与孔边平行 磁钢边平行
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➢ 垂直约束（Perpendicularity）

转子-设置约束

磁钢边垂直
磁钢边垂直 孔边垂直
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➢ 同步约束（Coincident）

转子-设置约束

下磁钢边与中孔边同步 中线与上中线同步上磁钢边与中线同步
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➢ 同步约束（Coincident）

转子-设置约束

轴中线与下中线同步 中线与中孔中线同步下中线与中孔中线同步
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➢ 设置圆角

转子-设置特征（Feature）

名称：RS1:Upper Slit R

半径0.5

名称：RS3:Lower Slit Inside Corner R

半径0.2

名称：RS2:Lower Slit Outside Corner R

半径1.3
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➢ 设置镜像

转子-设置特征（Feature）

➢ 注意：为方便后面进行极槽参数化，此处仍应设置圆周镜像！
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➢ 在Assembly上右键，选择Equations…，点击Add，增加参数。在Variable中输入参数名。参数类型可选择参数值、表
达式或者函数。例如输入参数名为SD1，类型选择参数值200，可添加描述。点击OK完成参数创建。

设置参数
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➢ 可设置多个参数进行参数化分析，以上磁钢位置为例，设置参数。

设置参数
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➢ 点击几何编辑器左上角 按键，选择Import Model，返回JMAG Designer界面。

定义形状参数化

➢ 2D Model上点右键New Study，选择Magnetic->Static Analysis，创建稳态磁场分析模型。
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➢ 在Study下方CAD Parameter上点击右键，选择Select CAD Parameters。在Varaibles下方DMAG1上打勾，并将变量名
命名为DMAG1,点击OK。

定义形状参数化
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➢ 在Study下方Case Control上点击右键，选择Create Cases。出现对话框中Type选择Table，设置如下值，点OK。共生
成5个case。

定义形状参数化
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➢ 右图可知Case1超出了图形范围，发生错误，其余Case正常变化。

定义形状参数化

Case1 Case2 Case3 Case4 Case5
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➢ 定义V型磁铁夹角。首先删除下方孔边与横线距离约束。定义下磁钢边与中线的角度约束，命名为V-Angle。

定义形状参数化
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➢ 定义参数V_Angle，导入JMAG Designer ,同样方式创建多个Case。

定义形状参数化
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